Как отключить рекомендуется обновить версию конфигурации?


В коде проверка выглядит так:
Функция ВерсияПрограммыУстарела() ДатаТекущейВерсии = Константы.ДатаТекущейВерсии.Получить(); Если ЗначениеЗаполнено(ДатаТекущейВерсии) Тогда Возврат ТекущаяДата() > ДобавитьМесяц(ДатаТекущейВерсии, 2); Иначе Возврат Ложь; КонецЕсли; КонецФункции

Из кода видно, что дата текущей версии конфигурации 1С Предприятия 8 хранится в константеДатаТекущейВерсии . Если в эту константу записать дату намного больше текущей, то требования обновиться больше не будут выводиться. То есть вы отключите данное сообщение.
Как отключить это уведомление:
Программно это делается это так (установим дату текущей версии на 01.01.2100 г.):

Константы.ДатаТекущейВерсии.Установить(Дата(‘21000101’));

Другой способ изменения настройки — через интерфейс.
Если у вас 1С 8.3 (например Бухгалтерия 3.0) тогда поступите так:

  1. Файл — Все функции
  2. В Константах находим Дата текущей версии
  3. Устанавливаем дату — 2100 год

Если же Вы используете более ранние конфигурации, производим те же самые функции через меню “Операции”.
На что эти действия могут повлиять?
Изменение значения константы на работу системы никак не повлияет. Следует также заметить, что при обновлении релиза конфигурации ДатаТекущейВерсии перезаписывается, поэтому эту процедуру следует повторять после каждого обновления.
Отключение самого окна в коде
Ну а если вам не хочется менять константу, но есть возможность изменить конфигурацию, то можно отключить напоминания так (для Бухгалтерии 2.0):
Модуль обычного приложения -> Процедура ПриНачалеРаботыСистемы. Закомментируйте строку:

КонтрольВерсииКонфигурации.ПроверитьВерсиюКонфигурации();

Как настроить автоматическое обновление конфигураций 1С:Предприятие 8 через Интернет

27.04.2016

Порядок настройки автоматического обновления типовой конфигурации системы 1С:Предприятие

Обратите внимание, что обновление типовых конфигураций, расположенных в облачном сервисе 1С:Фреш производится автоматически силами специалистов самой Фирмы 1С и не требует от пользователей каких-либо дополнительных действий. В стоимость доступа к облачной версии уже включено обновление и в большинстве случаев по стоимости выходит дешевле, чем подписка ИТС.
Получить доступ к облаку 1С:Фреш бесплатно на 30 дней!
В большинстве типовых конфигураций системы 1С:Предприятие 8 заложена возможность автоматического обновления конфигураций через Интернет.
Прежде чем приступать к настройке системы автоматического обновления обратите внимание на следующие моменты:

  • Необходим широкополосный доступ в Интернет.
  • Для возможности автоматического обновления типовой конфигурации необходимо выполнение условий:
    • Наличие действующей подписки на ИТС (для Базовых версий наличие подписки ИТС не обязательно).
    • Наличие у пользователя логина и пароля для доступа к порталу (или https://users.v8.1c.ru/).
    • Программный продукт должен быть зарегистрирован в личном кабинете пользователя на портале информационно-технологического сопровождения Фирмы «1С» portal.1c.ru
      Инструкция по регистрации программных продуктов в личном кабинете единого портала информационно-технологического сопровождения Фирмы «1С» portal.1c.ru
  • Автоматическое обновление предназначено для последовательного обновления с одного релиза на последующий (в некоторых случаях допускается пропуск одного-двух релизов) в пределах одной редакции (переход с одной редакции на другую не поддерживается). Если было пропущено несколько обновлений, то может понадобиться ручная установка промежуточных релизов. Подробнее ознакомиться с порядком обновления типовых конфигураций 1С:Предприятие 8 в ручном режиме можно .
  • Технология автоматического обновления предназначена для обновления только ТИПОВЫХ конфигураций, т.е. конфигураций в которые не вносилось НИКАКИХ изменений и настроек в режиме конфигурирования. Обновление изменённых конфигураций производиться вручную и требует специальных навыков.
  • Технология автоматического обновления конфигураций не предназначена для обновления платформы. Если для перехода с одного релиза конфигурации необходимо обновить платформу, то предварительно необходимо выполнить эту процедуру вручную.
  • В некоторых случаях для соединения с Интернетом потребуется дополнительно указать имя пользователя и пароль для доступа на прокси-сервер. Подробную информацию об использовании прокси-сервера можно получить у администратора вашей локальной сети.
  • Для обеспечения целостности и согласованности данных во время создания резервной копии и обновления конфигурации должна быть завершена работа всех пользователей с информационной базой. Также в это время не должны выполняться регламентные и фоновые задания: Для контроля за выполнением заданий и их отмены необходимо использовать обработку «Консоль заданий» с диска ИТС; Если существуют задания, выполняемые по расписанию, необходимо запретить их выполнение на время обновления конфигурации; При использовании файлового варианта работы с информационной базой для этого нужно завершить работу программы — планировщика заданий; В клиент-серверном варианте работы следует использовать утилиту администрирования, где нужно установить флаг «Блокировка регламентных заданий включена» в свойствах информационной базы; Если в конфигурации выполнялись доработки, вызывающие запуск фоновых заданий, следует запретить их выполнение на время обновления конфигурации. После обновления конфигурации выполнение заданий можно вновь разрешить.

Таким образом, использование механизма автоматического обновления можно порекомендовать небольшим организациям, имеющим стабильный и скоростной канал доступа в Интернет и в которых программа 1С:Предприятие 8 используется на небольшом количестве компьютеров:

  • во-первых: обновление запускается автоматически после его размещения на сайте технической поддержки «1С» и для процедуры обновления необходимо завершение работы всех пользователей, что для больших организаций часто неприемлемо;
  • во-вторых: процедура может занять продолжительное время в зависимости от скорости интернета (к времени обычной процедуры обновления необходимо добавить время закачки файла обновления по Интернет, который может быть размером в несколько десятков Мб);
  • в-третьих: в некоторых случаях при использовании нескольких компьютеров в сети для соединения с Интернетом потребуется дополнительно указать имя пользователя и пароль для доступа на прокси-сервер (информацией об использовании прокси-сервера должен владеть администратор вашей локальной сети).
  • в-четвертых: как правило, чем организация больше, тем чаще происходит индивидуальная настройка конфигураций под требования, не реализованные в типовых конфигурациях – технология автоматического обновления предназначена для обновления только типовых конфигураций.

Купить минимальный вариант подписки ИТС на 1 месяц за 4818 руб.
Настройка автоматического обновления конфигурации через Интернет
В статье использовались иллюстрации настройки обновления типовой конфигурации «1С:Бухгалтерия предприятия» редакции 3.0, релиз 3.0.43.173, с интерфейсом Такси.
Версия платформы 1С:Предприятие 8.3, релиз 8.3.6.2125, см.рис.

1. В разделе меню «Администрирование» выберете пункт «Интернет-поддержка пользователей».

Электронные поставки 1С — 100% лицензия! Купить максимально быстро!
2. Откроется окно «Интернет-поддержка пользователей». Если ранее подключение поддержки не было выполнено, то нажмите кнопку «Подключить».

Подключить «1С:Контрагент» для автозаполнения реквизитов по ИНН
3. В открывшемся окне укажите свои логин и пароль для доступа к порталу 1С https://portal.1c.ru/ (или https://users.v8.1c.ru/) и нажмите кнопку «Войти». Доступ к этим сайтам имеют только зарегистрированные пользователи программ системы 1С:Предприятие, имеющие действующую подписку на ИТС (для базовых версий подписка на ИТС не требуется).
Если подключение интернет-поддержки было выполнено правильно, то вы увидите статус «Подключена Интернет-поддержка для пользователя…».
Если же вы ранее уже подключали интернет-поддержку (например, для работы с сервисом 1С:Контрагент или другими сервисами 1С), то переходите к следующему пункту.
Подключить «1СПАРК Риски» для оценки надежности контрагентов
4. После этого нажмите «Настройка обновления программы через Интернет».
Купить электронную лицензию на сервер 1С:Предприятия 8.3 x64
5. В открывшемся окне потребуется еще раз указать свои логин и пароль для доступа к порталу 1С, а также можете выбрать один из трех способов проверки обновлений на сайте 1С:

  • Отключена (в этом случае проверка наличия обновления производится не будет, подходит в случае. если планируется ручная установка обновлений.
  • При запуске программы (проверка обновлений на сайте 1С будет производится при каждом запуске программы).
  • По заданному расписанию (необходимо задать расписание проверки наличия обновлений на сайте 1С).

Если хотите, чтобы система запомнила пароль и не спрашивала в следующий раз при автоматическом обновлении, поставьте флажок «Запомнить пароль».
Нажмите «ОК».
В примере выбран способ проверки «При запуске программы».
Если на сайте 1С имеется доступное обновление, то при следующем запуске программы система автоматического обновления проверит наличие более свежего релиза на сайте 1С и сообщит, что появился более свежий релиз (в примере 3.0.43.195).
6. Если кликнуть на это сообщение, то откроется окно активации обновления «Доступна новая версия программы», на котором будут отображены номер версии, размер обновления и предложение установить обновление. Нажимаем «Далее».
Если на пользовательском сайте имеется доступное обновление, то система сообщает номер версии, краткое описание, размер обновления и предлагает его установить.
7. Можно выбрать «Установить обновление прямо сейчас» или «Напомнить при завершении работы».

Примечание.
Перед началом обновления необходимо завершить работу пользователей, подключенных к информационной базе (в том числе работу Конфигуратора). В случае, если система обнаружит работающих пользователей в режиме 1С:Предприятие или Конфигуратора то появиться сообщение о невозможности продолжения и необходимости завершения работы.

После нажатия на кнопку «Далее» программа устанавливает соединение с сайтом технической поддержки 1С, используя указанные код пользователя и пароль, и получает файл обновления локально на компьютер. Получение файла обновления с пользовательского сайта может занять продолжительное время, в зависимости от размера конкретного файла обновления и скорости подключения к Интернету.
8. Если планируете устанавливать обновление прямо сейчас, то обязательно нажмите «Создавать временную резервную копию ИБ и выполнять откат при нештатной ситуации».
9. В открывшемся окне можете выбрать способ создания резервной копии (сохранять во временной папке, указать каталог, в который необходимо сохранить архивную копию или вовсе не создавать архивной копии).
10. После сохранения резервной копии нажмите кнопку «Далее» в предыдущем окне.
Запустится процесс установки обновлений, который в зависимости от производительности компьютера и размера информационной базы может занять довольно продолжительное время (обычно 15-45 минут). Не выключайте питание компьютера до завершения процесса.
11. После завершения обновления конфигурации 1С:Предприятие появится сообщение об успешном завершении обновления. Нажмите «Готово».
Программа будет автоматически перезапущена и откроется описание изменений установленного обновления.
Внимательно ознакомьтесь с изменениями, которые были внесены в конфигурацию. Возможно, имеются процедуры, которые дополнительно необходимо выполнить вручную. Если вы закрыли это окно, то чтобы открыть его снова в разделе «Администрирование» нажмите «Поддержка и обслуживание» > «Результаты обновления программы».

Проверяем данные программы
Релиз конфигурации успешно обновился с 3.0.43.173 до 3.0.43.195

Дополнительная информация

  • Временная резервная копия базы данных 1С в ОС Windows 10, 8, 7 по умолчанию сохраняется в каталог вида C:\Users\%user%\AppData\Local\Temp\1Cv8Update.160427132115, где цифры после точки означают: 16 – год, 04 – месяц, 27 – день, 13 – часы, 21 – минуты, 15 – секунды. В этом каталоге сохраняется файл с архивной копией базы данных с расширением «*.1CD» и log-файл с расширением «*.txt».
  • Записи о произведенных операциях и возникших ошибках в ходе обновления заносятся в Журнал регистрации информационной базы (тип события «Обновление информационной базы»).
  • В процессе установки обновления во временной папке текущего пользователя Windows создается лог-файл с записями о ходе обновления. (Содержимое лог-файла впоследствии автоматически добавляется в Журнал регистрации.).
  • Результат обновления информационной базы записывается в Журнал событий Windows (Event Log).

Если данная информация оказалась для вас полезной, то лайкаем статью в соцсетях и делимся ссылкой на любимых форумах ))).

© Компания «Онлайн» 2016, www.online-ufa.ru

Ключевые слова

автообновление 1с, автоматическое обновление 1с, как самому обновить 1с 8.3, автоматическое обновление 1с 8.3, 1с автоматическое обновление конфигурации, автоматическое обновление 1с настройка, автоматическое обновление клиентов 1с, автоматическое обновление 1с 8.2, настроить автоматическое обновление 1с, как самому обновить 1с 8.4, автообновление 1с 8.3, автоматическое обновление базами 1с, автоматическое обновление 1с 8, автоматическое обновление клиента 1с 8.3, автоматическое обновление конфигурации 1с 8.3, автоматически не обновляется конфигурация 1с 8.3, не обновляется 1с 8.3 через интернет, не обновляется база 1с 8.3, как настроить чтобы 1с обновлялась сама, инструкция по настройке автообновления 1с, как настроить автоматическое обновление 1с 8.3, автоматическое обновление 1с 8.3 бухгалтерия, настройка автоматического обновления 1с 8.3, автоматическое обновление тонкого клиента 1с, инструкция по обновлению 1с в автоматическом режиме, автоматическое обновление платформы 1с на клиенте, 1с не обновляется конфигурация, при автоматическом обновлении 1с куда сохраняется архив, самой настроить обновление 1с, настройка автоматического обновления 1с 8.3, куда сохраняется база 1с при автоматическом обновлении, настройка автоматического обновления 1с комплексная 8, 1с автообновление конфигураций, автоматическое обновление 1с 8.3 через интернет, скрипт автоматического обновления конфигураций 1с 8.3, как обновить 1с в автоматическом режиме, обновить 1с 8.3, как самому настроить автоматическое обновление 1с, обновить 1с бухгалтерия 8.3, как обновить 1с самостоятельно, настройка автообновления 1с, как обновить 1с 8.3 самостоятельно, как обновить конфигурацию 1с, обновить конфигуратор 1с, как обновить платформу 1с, 1с бухгалтерия обновить, как обновить 1с без конфигуратора, обновить версию 1с, обновить конфигурацию 1с 8.3, обновить 1с 8.3 через конфигуратор, бесплатно обновить 1с, как обновить конфигуратор 1с 8.3, как обновить 1с 8.2 самостоятельно, как обновить 1с через интернет, обновить базу 1с, обновить программу 1с, как обновить 1с 8.3 самостоятельно через конфигуратор, обновлять релизы 1с, как обновить платформу 1с 8.3 самостоятельно, как обновить 1с 8, обновить 1с 3.0 в фоновом режиме, обновить 1с через интернет самостоятельно, обновить 1с 8.3 бесплатно, 1с бухгалтерия 8.3 как обновить, обновить 1с через интернет бесплатно, как обновить 1с предприятие, как обновить базовую 1с, как обновлять 1с 8.4, как обновить конфигурацию 1С, как обновить 1с 8.3 самостоятельно через интернет, обновить конфигуратор 1с 8.4, обновить 1с 8.4 через конфигуратор, обновить 1с до последней версии, обновить версию 1с 8.3, обновить 1с 8.3 самостоятельно бесплатно, как обновить 1с 8.4 самостоятельно через конфигуратор, не обновляется 1с, не обновляется 1с 8.3, почему не обновляется 1с 8.4, почему 1с обновляется, 1с бухгалтерия обновляется, 1с 8 обновляется, обновляется релиз 1с, как настроить автообновление 1с самостоятельно, 1с не обновляется через интернет, не обновляется конфигурация 1с 8.3, 1с обновляется автоматически, почему 1с не обновляется автоматически, не запускается автоматическое обновление 1с, как запустить автообновление 1С, почему не обновляется 1с 8.3 в фоновом режиме, долго обновляется 1с 8.3, 1с не обновляется конфигурация базы данных, самой обновить 1с, обновляется 1с 8.2 бухгалтерия, не обновляется конфигурация базы данных 1с 8.4, 1с 8.3 автоматически обновляется, почему не обновляется 1с 8.3 базовая, 1с 8 не обновляется конфигурация, почему не обновляется 1с конфигурация 8.3, не обновляется 1с 8.4 через интернет, обновляется 1с 8.4 8.3, почему не обновляется 1с 8.2 базовая, не обновляется 1с 8.3 что делать, как обновляется 1с 8.3 базовая, 1с бгу не обновился план счетов, 1с бп платформа 8.3 не обновляется, сколько по времени обновляется 1с 8.3 в автоматическом режиме, 1с 8 обновляется автоматически

Как исправить ошибку «EF_XXXXXXXX» процедура или функция с указанным именем уже определена оглавление Как и зачем отключать защиту от опасных действий?

Обновлятор-1с. Как отключить расширения на время выполнения обработчиков обновления (v2)?

Обновлятор >> Инструкции 2019-12-20T14:55:18+00:00

Зачем

Наличие подключённых расширений в некоторых случая может являться препятствием для программного выполнения обработчиков обновления (через внешнее соединение с базой).

К примеру, наличие в базе активного расширения меняющего роли основной конфигурации приведёт вот к такой ошибке при попытке выполнить обработчики обновления программно:

«обновление параметров работы программы не может быть выполнено,, т.к. подключены расширения конфигурации, модифицирующие права в ролях конфигурации., для выполнения обновления необходимо отключить такие расширения.»

Более того последние версии типовых конфигураций (по состоянию на декабрь 2019 года) требуют временного отключения любых установленных расширений при программном выполнении обработчиков обновления, если база файловая:

Ошибка: {регистрсведений.параметрыработыпрограммы.модульменеджера(375)}: обновление параметров работы программы, когда подключены расширения конфигурации,, может быть выполнено только в фоновом задании без расширений конфигурации., , в файловой информационной базе фоновое задание невозможно запустить, из другого фонового задания, а также из com-соединения., , для выполнения обновления необходимо, либо делать обновление интерактивно, через запуск 1с:предприятия, либо временно отключать расширения конфигурации.

Обновлятор позволяет выключать расширения конфигурации (без их удаления) на время выполнения обработчиков обновления, а затем включать снова.

При этом включает он только те расширения, что были активны до выполнения обработчиков обновления. То есть если расширение было выключено до обновления базы, то оно останется выключенным и после.

Как

За выключение расширений на время выполнения обработчиков обновления отвечает галка «Отключать расширения на время выполнения обработчиков обновления», она находится в свойствах базы на закладке «Обновление»:

При установке этой опции результат выполнения обработчиков обновления будет таким:

Опцию нельзя отключить для файловых баз

При этом для файловых баз эта опция установлена принудительно без возможности выключения. Это связано с тем, что последние версии типовых конфигураций (по состоянию на декабрь 2019 года) требуют отключения любых установленных расширений, если база файловая.

С уважением, Владимир Милькин (преподаватель школы 1С программистов и разработчик обновлятора).
Обновлятор >> Инструкции

Подписывайтесь и получайте новые статьи и обработки на почту (не чаще 1 раза в неделю).
Вступайте в мою группу ВКонтакте, Одноклассниках, Facebook или Google+ — самые последние обработки, исправления ошибок в 1С, всё выкладываю там в первую очередь.

Как помочь сайту: расскажите (кнопки поделиться ниже) о нём своим друзьям и коллегам. Сделайте это один раз и вы внесете существенный вклад в развитие сайта. На сайте нет рекламы, но чем больше людей им пользуются, тем больше сил у меня для его поддержки.

Нажмите одну из кнопок, чтобы поделиться:

Как исправить ошибку «EF_XXXXXXXX» процедура или функция с указанным именем уже определена оглавление Как и зачем отключать защиту от опасных действий?

1с описание оповещения

Admin 2 марта, 2020

Недавно писал статью про 1с сообщения и понял, что я не совсем уверенно работаю с таким объектом как ‘описание оповещения’. Решил закрепить эти знания в виде заметки! Надеюсь и вам она будет полезна.

Итак, описание оповещения – это описание вызова процедуры с дополнительными параметрами, вызов которой будет осуществлен при наступлении определенного события: к примеру закрытие формы или не модального диалога. То есть это по сути дополнительная процедура, которая поможет нам обработать интерактивные действия с 1с.

Давай для примера напишем оповещение для пользователя и при нажатии на это оповещение выполним какие-либо необходимые для нас действия:

1С (Код)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 &НаСервере Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка) ЭтаФорма.Сайт = «www.Craft1c.ru»; КонецПроцедуры &НаКлиенте Процедура ПриОткрытии(Отказ) //Сайт — реквизит формы ТекстОповещения = «www.Craft1c.ru — заходи, читай и качай!»; СтруктураПараметров = Новый Структура; СтруктураПараметров.Вставить(«Сайт», Сайт); ДействиеПриНажатии = Новый ОписаниеОповещения(«ОбработкаСообщенияПользователю», ЭтотОбъект, СтруктураПараметров); Пояснение = «Просто пояснение craft1c»; Картинка = БиблиотекаКартинок.Справка; Статус = СтатусОповещенияПользователя.Важное; КлючУникальности = Неопределено; ПоказатьОповещениеПользователя(ТекстОповещения, ДействиеПриНажатии, Пояснение, Картинка, Статус, КлючУникальности); КонецПроцедуры &НаКлиенте Процедура ОбработкаСообщенияПользователю(ДополнительныеПараметры) Экспорт //Если написать так: //»ОбработкаСообщенияПользователю(Результат, ДополнительныеПараметры) Экспорт», то будет ошибка //В методе ОбработкаСообщенияПользователю количество параметров 2. Ожидаемое количество — 1. //в данном случае нужен один параметр — с дополнительными параметрами Если ДополнительныеПараметры.Свойство(«Сайт») Тогда Сообщить(ДополнительныеПараметры.Сайт); КонецЕсли; КонецПроцедуры

Тут все довольно-таки просто. Рассмотрим основные параметры описания оповещения в нашем примере:

  • 1-ый параметр: вызываемся процедура. ‘ОбработкаСообщенияПользователю’ – в данном случае это экспортная процедура модуля формы, в которым мы находимся. Стоит заметить что я раньше считал, что процедура может быть только клиентской. Но нет, если мы этот же пример рассмотрим и с процедурой на сервере, то так же все будет работать. Причем она в этом случае может быть и не экспортная – об этом даже есть обсуждение на инфостарте.
  • 2-ой параметр: объект, где находится наша вызываемая процедура. Поскольку в данном случае она находится в том же месте, где идет описание оповещения, то указываем ‘ЭтотОбъект’!
  • 3-ий параметр: структура дополнительных параметров, которые мы хотим использовать в процедуре обработки оповещения. Вставляем любые параметры и обрабатываем их!

Здесь стоит обратить внимание на 1 нюанс: в данном случае в нашей экспортной процедуре 1 параметр – и это дополнительные параметры. Но бывают случаи, когда параметров у нашей экспортной процедуры будет несколько. К примеру давайте создадим оповещение для вопроса пользователю:

1С (Код)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 &НаКлиенте Процедура ЗадачтьВопрос(Команда) Оповещение = Новый ОписаниеОповещения(«ПослеЗакрытияВопроса», ЭтотОбъект); ПоказатьВопрос(Оповещение, «www.Craft1c.ru?», РежимДиалогаВопрос.ДаНетОтмена, 0, КодВозвратаДиалога.Да, «Это вопрос!»); //это не модальный вызов ворпоса, код будет выполнен до конца, пока вопрос висит у пользователя! Сообщить(«craft1c»); КонецПроцедуры &НаКлиенте Процедура ПослеЗакрытияВопроса(Результат, ДополнительныеПараметры) Экспорт Если Результат = КодВозвратаДиалога.Да Тогда Сообщить(«Отлично!»); КонецЕсли; КонецПроцедуры

Как можем видеть, в данном случае еще должен быть параметр ‘Результат’, в противном случае мы получим ошибку ‘… количество параметров 1. Ожидаемое количество – 2’:

Количество параметров 1. Ожидаемое количество – 2.

В справке EDT этот момент удобно описан, так что промазать с количеством параметров будет тяжело:

Параметры процедуры оповещения.Параметры процедуры оповещения.

Не знание данного вопроса украло у меня ценное время разработки.

Итак, идем дальше. А что если мы хотим нашу процедуру поместить в общем модуле? А все очень просто – для этого в описании оповещения мы указываем общий модуль (просто его название), где находится наша процедура:

1С (Код)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 &НаКлиенте Процедура ПриОткрытии(Отказ) //Сайт — реквизит формы ТекстОповещения = «www.Craft1c.ru — заходи, читай и качай!»; СтруктураПараметров = Новый Структура; СтруктураПараметров.Вставить(«Сайт», Сайт); ДействиеПриНажатии = Новый ОписаниеОповещения(«ОбработкаСообщенияПользователю», ОбщийМодульКлиент, СтруктураПараметров); Пояснение = «Просто пояснение craft1c»; Картинка = БиблиотекаКартинок.Справка; Статус = СтатусОповещенияПользователя.Важное; КлючУникальности = Неопределено; ПоказатьОповещениеПользователя(ТекстОповещения, ДействиеПриНажатии, Пояснение, Картинка, Статус, КлючУникальности); КонецПроцедуры //Процедура в общем модуле ОбщийМодульКлиент &НаКлиенте Процедура ОбработкаСообщенияПользователю(ДополнительныеПараметры) Экспорт Если ДополнительныеПараметры.Свойство(«Сайт») Тогда Сообщить(«Привет из общего модуля:» + ДополнительныеПараметры.Сайт); КонецЕсли; КонецПроцедуры

1с описание оповещения общий модуль.

И все так же будет отлично работать:

Результат работы процедуры из общего модуля.

Так же с помощью описания оповещения можно легко обрабатывать результат выбора пользователя. Более подробно можете ознакомиться в данной статье:

1С (Код)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 &НаКлиенте Процедура РаспределениеНоменклатураНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; ПараметрыВФорму = Новый Структура(«ТекущаяСтрока», ПолучитьОсновнуюГруппуВыбораНоменклатуры()); СтруктураПараметровОповещения = Новый Структура(); СтруктураПараметровОповещения.Вставить(«ПараметрДляТеста», «craft1c»); ОписаниеВыбора = Новый ОписаниеОповещения(«ОбработкаВыбораНоменклатуры», ЭтаФорма, СтруктураПараметровОповещения); ОткрытьФорму(«Справочник.Номенклатура.ФормаВыбора» ,ПараметрыВФорму , , , , , ОписаниеВыбора, РежимОткрытияОкнаФормы.БлокироватьОкноВладельца); КонецПроцедуры &НаКлиенте Процедура ОбработкаВыбораНоменклатуры(РезультатЗакрытия, ДопПараметры) Экспорт Если Не ЗначениеЗаполнено(РезультатЗакрытия) Тогда Возврат; КонецЕсли; Контейнер = Элементы.Распределение.ТекущиеДанные; Если Не Контейнер = Неопределено Тогда Контейнер.Номенклатура = РезультатЗакрытия; КонецЕсли; КонецПроцедуры

Описание оповещения так же отлично подойдет и для организации выбора из списка:

1С (Код)

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 &НаКлиенте Процедура ТипЗаявкиНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка) СтандартнаяОбработка = Ложь; ОповещениеВыборИзСписка = Новый ОписаниеОповещения(«ОбработкаВыбораИзСписка», ЭтотОбъект, Элемент); ПоказатьВыборИзСписка(ОповещениеВыборИзСписка, СписокВыбораТипЗаявки, Элемент); КонецПроцедуры &НаКлиенте Процедура ОбработкаВыбораИзСписка(ВыбЗначение, Элемент) Экспорт Если НЕ ВыбЗначение = Неопределено Тогда Объект.ТипЗаявки = ВыбЗначение.Значение; ТипЗаявкиПриИзменении(Элемент); КонецЕсли; КонецПроцедуры // ОбработкаВыбораИзСписка()

В общем активно используйте описание оповещения в интерактивных действиях! Ведь этот очень просто и тем более удобно. Долой модальность!

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *